Elevated 500 rates
Incident Report for Persona
Resolved
The root cause has been identified and fixed. All services are now operational.
Posted May 30, 2023 - 20:05 UTC
Investigating
Customers are experiencing elevated 500 rates on several products.
Posted May 30, 2023 - 19:50 UTC
This incident affected: Dashboard, Verifications, and Inquiries & Collections.