Elevated 500 rates
Incident Report for Persona
Resolved
This incident has been resolved.
Posted Jul 19, 2023 - 14:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2023 - 14:11 UTC
Identified
Customers are experiencing elevated 500 rates on several products.
Posted Jul 19, 2023 - 14:02 UTC
This incident affected: Dashboard, Verifications, and Inquiries & Collections.