Report processing is delayed
Incident Report for Persona
Resolved
We have resolved this issue
Posted Nov 09, 2020 - 22:31 UTC
Update
We are continuing to investigate this issue.
Posted Nov 09, 2020 - 22:30 UTC
Update
We are continuing to investigate this issue.
Posted Nov 09, 2020 - 21:41 UTC
Investigating
We are currently investigating the issue.
Posted Nov 09, 2020 - 21:40 UTC
This incident affected: Dashboard and API.