Intermittent Increased Latency Across Multiple Products
Incident Report for Persona
Resolved
All services are now operational.
Posted Aug 07, 2023 - 23:53 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 07, 2023 - 22:06 UTC
Update
We have identified the issue and deployed a fix.
Posted Aug 07, 2023 - 21:09 UTC
Monitoring
We are experiencing intermittently increased latency with our address look-up service. This may be impacting Database Verifications, Address Lookup Reports, Database Business (BRV), and select Graph Queries.
Posted Aug 07, 2023 - 19:10 UTC
This incident affected: Reports, Verifications, Workflows, and Graph.