Government ID and Selfie Verification Failures
Incident Report for Persona
Resolved
All services are operational.
Posted May 30, 2023 - 12:21 UTC
Monitoring
A fix has been implemented, all services are now operational.
Posted May 30, 2023 - 12:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 30, 2023 - 11:58 UTC
Investigating
We are currently investigating elevated failures in government ID and selfie verifications.
Posted May 30, 2023 - 11:19 UTC
This incident affected: Verifications.