Persona Transactions temporarily unavailable
Resolved·Degraded performance

Our systems are fully operational.

Fri, Sep 12, 2025, 07:35 PM
(1 week ago)
·
Affected components
Dashboard
Updates

Resolved

Our systems are fully operational.

Fri, Sep 12, 2025, 07:35 PM

Monitoring

The previously observed degraded performance of Transactions is now recovering. We're monitoring our systems and expect to share a final update soon.

Fri, Sep 12, 2025, 06:41 PM(53 minutes earlier)

Identified

We're seeing degraded performance for Persona Transactions. We have identified the cause and are introducing a fix.

Fri, Sep 12, 2025, 04:11 PM(2 hours earlier)

Investigating

We're observing limited availability on the Persona Dashboard. More details to follow shortly.

Fri, Sep 12, 2025, 04:01 PM(10 minutes earlier)