No components marked as affected
Resolved
Starting on September 11, 2025 23:30 UTC, we saw elevated latency across our platform. Our systems are recovered as of September 12, 2025 00:30 UTC.
Monitoring
We have recovered and are now monitoring this latency event. More details on cause to follow shortly.
Investigating
We are seeing increased latency across the platform. Updates to follow shortly.