Increased latency
Resolved

Between 14:11 UTC to 14:35 UTC, we saw elevated response times impacting customers in our US region. This is now resolved.

Fri, Aug 29, 2025, 02:52 PM
(4 days ago)
·
Affected components

No components marked as affected

Updates

Resolved

Between 14:11 UTC to 14:35 UTC, we saw elevated response times impacting customers in our US region. This is now resolved.

Fri, Aug 29, 2025, 02:52 PM

Investigating

We're currently investigating elevated response times that started at 14:11 UTC impacting customers in our US region. We'll post an update soon.

Fri, Aug 29, 2025, 02:38 PM(14 minutes earlier)