Widespread platform outage due to Google Cloud issues
Resolved·Full outage

We have now fully recovered from the Google Cloud outage. All systems are operational. Thank you for your patience.

Thu, Jun 12, 2025, 10:17 PM
(1 day ago)
·
Affected components
API
Dashboard
Reports
Verifications
Workflows
Graph
Inquiries & Collections
Webhooks
Cases
Updates

Resolved

We have now fully recovered from the Google Cloud outage. All systems are operational. Thank you for your patience.

Thu, Jun 12, 2025, 10:17 PM

Monitoring

We have now fully recovered from the Google Cloud outage. All systems are operational. Thank you for your patience.

Thu, Jun 12, 2025, 10:13 PM

Monitoring

We have recovered in all regions and are closely monitoring systems as traffic resumes. We will continue to work with Google Cloud to root cause the issues.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Thu, Jun 12, 2025, 09:07 PM(1 hour earlier)

Monitoring


We have recovered in all regions and are closely monitoring systems as traffic resumes. We will continue to work with Google Cloud to root cause the issues.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Thu, Jun 12, 2025, 08:49 PM(17 minutes earlier)

Monitoring

We have recovered in all regions and are closely monitoring systems as traffic resumes. We will continue to work with Google Cloud to root cause the issues.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Thu, Jun 12, 2025, 08:34 PM(15 minutes earlier)

Identified

Google Cloud is beginning to recover. Traffic in our EU region has recovered. Our US region is starting to recover.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Thu, Jun 12, 2025, 08:20 PM(13 minutes earlier)

Identified

Google Cloud is beginning to recover. Traffic in our EU region has recovered. Our US region is starting to recover.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Thu, Jun 12, 2025, 08:16 PM

Identified

Google Cloud is beginning to recover. Traffic in our EU region has recovered. Our US region remains down.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Thu, Jun 12, 2025, 08:12 PM

Identified

Google Cloud is beginning to recover. Traffic in our EU region has recovered. Our US region remains down.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Thu, Jun 12, 2025, 07:56 PM(16 minutes earlier)

Identified

We are continuing to investigate this issue with Google Cloud.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Thu, Jun 12, 2025, 07:42 PM(13 minutes earlier)

Identified

We are continuing to investigate this issue with Google Cloud.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Thu, Jun 12, 2025, 07:36 PM

Identified

We are continuing to investigate this issue with Google Cloud.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Thu, Jun 12, 2025, 07:20 PM(16 minutes earlier)

Identified

We are continuing to investigate this issue with Google Cloud.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Thu, Jun 12, 2025, 07:14 PM

Identified

We are continuing to investigate this issue with Google Cloud.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Thu, Jun 12, 2025, 07:09 PM

Identified

We are continuing to investigate this issue with Google Cloud.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Thu, Jun 12, 2025, 07:02 PM

Identified

Google Cloud is working on this issue.

Thu, Jun 12, 2025, 06:59 PM

Identified

We are continuing to investigate this issue with Google Cloud.

Thu, Jun 12, 2025, 06:46 PM(12 minutes earlier)

Identified

We are continuing to investigate this issue with Google Cloud.

Thu, Jun 12, 2025, 06:40 PM

Identified

We are continuing to investigate this issue with Google Cloud.

Thu, Jun 12, 2025, 06:34 PM

Identified

Google Cloud is working on this issue.

Thu, Jun 12, 2025, 06:29 PM

Investigating

We are experiencing a widespread outage across our platform in all regions due to a severe ongoing issue with Google Cloud.

Thu, Jun 12, 2025, 06:08 PM(20 minutes earlier)