Snowflake outage affecting Analytics in the Dashboard in US region.
Resolved

Snowflake has resolved their issue. Analytics views are available and all analytic data is now up-to-date in our systems.

Thu, Jun 12, 2025, 09:00 AM
(1 month ago)
·
Affected components

No components marked as affected

Updates

Resolved

Snowflake has resolved their issue. Analytics views are available and all analytic data is now up-to-date in our systems.

Thu, Jun 12, 2025, 09:00 AM

Monitoring

The issue affecting the Analytics section of our dashboard has been addressed, and functionality is beginning to recover. We're actively monitoring to confirm that everything is back to normal.

Thu, Jun 12, 2025, 06:10 AM(2 hours earlier)

Identified

We’re currently experiencing an issue affecting the Analytics sections of our dashboard due to a Snowflake outage. All other services are operating normally. We'll post an update once service is back up.

Thu, Jun 12, 2025, 03:37 AM(2 hours earlier)