Intermittent spikes in latency and 503s (US1 and US2)
Resolved

Between 5:28 AM UTC and 8:06 AM UTC we saw intermittent increased latency, resulting in increased workflow runtimes and periodic bursts of 503s for customers using transactions. This is now resolved and latency across the platform has returned to pre-incident levels.

Fri, May 23, 2025, 08:11 AM
(9 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

Between 5:28 AM UTC and 8:06 AM UTC we saw intermittent increased latency, resulting in increased workflow runtimes and periodic bursts of 503s for customers using transactions. This is now resolved and latency across the platform has returned to pre-incident levels.

Fri, May 23, 2025, 08:11 AM

Investigating

We have been seeing intermittent increased latency since 5:28 AM UTC, resulting in increased workflow runtimes and periodic bursts of 503s for customers using transactions. Our team is actively investigating the issue.

Fri, May 23, 2025, 07:49 AM(22 minutes earlier)