Increased Latency for Workflows Processing
Resolved·Degraded performance


Between 6:48 PM UTC and 7:04 PM UTC, we saw elevated response times across workflows. This is now resolved.

Sat, May 3, 2025, 09:14 PM
(9 months ago)
·
Affected components
Workflows
Updates

Resolved


Between 6:48 PM UTC and 7:04 PM UTC, we saw elevated response times across workflows. This is now resolved.

Sat, May 3, 2025, 09:14 PM

Monitoring

Between 6:48 PM UTC and 7:04 PM UTC, we saw elevated response times across workflows. This is now resolved.

Sat, May 3, 2025, 07:30 PM(1 hour earlier)

Investigating

We are currently investigating increased latency on Workflows processing in the US region.

Sat, May 3, 2025, 06:48 PM(41 minutes earlier)