Increased latency
Resolved·Degraded performance

Between 2:54 PM UTC and 3:28 PM UTC, we saw elevated response times in our US region. This is now resolved.

Thu, May 1, 2025, 05:33 PM
(9 months ago)
·
Affected components
API
Workflows
Updates

Resolved

Between 2:54 PM UTC and 3:28 PM UTC, we saw elevated response times in our US region. This is now resolved.

Thu, May 1, 2025, 05:33 PM

Monitoring

Between 2:54 PM UTC and 3:28 PM UTC, we saw elevated response times in our US region. This is now resolved.

Thu, May 1, 2025, 03:59 PM(1 hour earlier)

Investigating

We're currently investigating elevated response times for traffic being processed in our US region. We'll post an update soon.

Thu, May 1, 2025, 03:07 PM(52 minutes earlier)