Elevated Response Times
Resolved

We have not observed any further elevated latency since 20:07 UTC. We are considering this issue to be resolved and will be continuing to monitor internally.

Thu, Apr 24, 2025, 08:57 PM
(3 weeks ago)
·
Affected components

No components marked as affected

Updates

Resolved

We have not observed any further elevated latency since 20:07 UTC. We are considering this issue to be resolved and will be continuing to monitor internally.

Thu, Apr 24, 2025, 08:57 PM

Monitoring

We've observed additional instances of slightly elevated response times around 17:30 UTC and have re-opened this incident. We are continuing to monitor on our side.

Thu, Apr 24, 2025, 05:39 PM(3 hours earlier)

Resolved

Between 15:21 and 16:34, we saw elevated response times across our systems. We have now fully recovered and have observed latencies return to normal levels.

Thu, Apr 24, 2025, 04:43 PM(56 minutes earlier)

Monitoring

Between 15:21 and 16:34, we saw elevated response times across our systems. We have now recovered and are observing latencies return to normal levels. We are continuing to monitor and will provide another update shortly.

Thu, Apr 24, 2025, 04:38 PM

Identified

We're currently investigating elevated response times in our US region beginning around 15:21 UTC. We have identified the cause and are working on a fix

Thu, Apr 24, 2025, 04:17 PM(21 minutes earlier)

Investigating

We're currently investigating elevated response times. We'll post an update soon.

Thu, Apr 24, 2025, 04:06 PM(11 minutes earlier)