Degraded inquiry experience
Resolved·Degraded performance

This incident has been resolved.

Sat, Nov 7, 2020, 02:25 AM
(4 years ago)
·
Affected components
API
Updates

Resolved

This incident has been resolved.

Sat, Nov 7, 2020, 02:25 AM

Identified

We've identified a few potential root causes for some of the latency seen from our servers. We will deploy the fixes for them within the hour and will continue monitoring.

Sat, Nov 7, 2020, 02:01 AM(23 minutes earlier)

Investigating

Individuals may experience waiting several minutes to proceed in an inquiry.

Fri, Nov 6, 2020, 11:19 PM(2 hours earlier)