Between 15:07 UTC and 16:31 UTC, AAMVA verifications were unavailable due to an issue originating from AAMVA's source network. Services have been fully restored as of 16:31 UTC.
We are expecting a Root Cause Analysis (RCA) report directly from AAMVA. We will share further details as they become available.
We apologize for any disruption this may have caused.
Resolved
Between 15:07 UTC and 16:31 UTC, AAMVA verifications were unavailable due to an issue originating from AAMVA's source network. Services have been fully restored as of 16:31 UTC.
We are expecting a Root Cause Analysis (RCA) report directly from AAMVA. We will share further details as they become available.
We apologize for any disruption this may have caused.
Investigating
We are continuing to investigate the ongoing AAMVA service outage. AAMVA verifications remain unavailable at this time. Our team is actively working to restore service and is in contact with AAMVA. We will provide another update in 30 minutes or sooner if the situation changes.
Investigating
Persona is currently investigating erroring AAMVA verifications. We are working directly with AAMVA to identify the root cause and will provide updates as we learn more.