Resolved
Between 03:05 and 05:53 UTC (June 10th), we saw elevated response times across government ID and selfie verifications in the US region, caused by a degradation in Google Cloud Storage. This is now resolved.
Identified
We're currently monitoring elevated response times affecting government ID and selfie verifications in the US region. The delays are linked to a degradation in our cloud storage provider (Google Cloud Storage). We are monitoring GCS's status and will update as soon as we have more information.
Investigating
We're currently investigating elevated response times in the US region, impacting government ID and selfie verifications. We'll post an update soon.