No components marked as affected
Resolved
Correction the issue was between 21:40 UTC - 22:22 UTC
Resolved
On April 27, between 9:39 and 10:21 UTC, we experienced elevated latency affecting Selfie and Government ID verifications. The issue was mitigated by disabling and rolling back recent model changes that were contributing to the increased latency.