Resolved – Clarification
Earlier, we notified you of a potential increase in verification latency. The increase was briefly impacting p95 and should not have been noticeable for the majority of customers.
This notification was triggered prematurely in the spirit of transparency, we apologize for any confusion caused. All systems have been operating normally.
Resolved
Resolved – Clarification
Earlier, we notified you of a potential increase in verification latency. The increase was briefly impacting p95 and should not have been noticeable for the majority of customers.
This notification was triggered prematurely in the spirit of transparency, we apologize for any confusion caused. All systems have been operating normally.
Monitoring
Verification latency has improved following mitigation efforts.
Investigating
Starting at 3:00 UTC, March 25, we are investigating an issue causing an increase in tail latencies for verifications.
Our team is actively working to identify the root cause and restore normal performance. We will provide updates as more information becomes available.