Persona

Help CenterSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Elevated Workflow completion time on US Legacy
Resolved·Degraded performance

Between 12:01 am and 12:15am UTC, we saw degraded performance with
Workflows on our US1 region. Workflow completion times were elevated during this period.
This is now resolved.

Sun, Mar 22, 2026, 12:15 AM
(3 months ago)
·
Affected components
Mar 22, 2026, 12:01 AM
12:15 AM
Workflows
Updates

Resolved

Between 12:01 am and 12:15am UTC, we saw degraded performance with
Workflows on our US1 region. Workflow completion times were elevated during this period.
This is now resolved.

Sun, Mar 22, 2026, 12:15 AM

Identified

Since 12:01 am UTC, we saw degraded performance with
Workflows on our US1 region. Workflow completion times were elevated during this period.
We've identified the cause and are working on resolving the issue.

Sun, Mar 22, 2026, 12:01 AM(14 minutes earlier)