Resolved
We experienced elevated latency in our workflows product between 22:36 UTC and 23:15 PM UTC in the US region. This is now resolved.
Monitoring
We experienced elevated latency in our workflows product between 22:36 UTC - 23:15 PM UTC. We have returned to normal operating levels and are currently monitoring the situation.
Investigating
Acknowledge (investigating) - We're currently investigating elevated response times with event-triggered workflows in the US region. We'll post an update soon.