Resolved
Between 9:50 PM UTC and 10:55 PM UTC, we saw elevated latency across workflows. This is now resolved.
Monitoring
Starting 9:50 PM UTC, we saw increased latency across workflows. A fix has been applied. We're seeing improvement and continuing to monitor performance.
Investigating
Since 9:50 PM UTC, we've seen elevated workflow latency. We'll post an update soon.