Persona

Help CenterSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Degraded performance
Resolved·Full outage

We are fully operational, the incident has been closed.

Wed, Feb 4, 2026, 09:16 PM
(4 months ago)
·
Affected components
Feb 4, 2026, 07:36 PM
09:16 PM
API
Dashboard
Verifications
Inquiries & Collections
Updates

Resolved

We are fully operational, the incident has been closed.

Wed, Feb 4, 2026, 09:16 PM

Monitoring

All functionality has been restored and we are fully operational. We are continuing to monitor.

Wed, Feb 4, 2026, 09:08 PM

Monitoring

We are currently processing all transactions, inquiries, workflows and verification.

We are continuing to monitor to ensure full functionality has been restored.

Wed, Feb 4, 2026, 08:45 PM(23 minutes earlier)

Identified

All transactions-based flow are fully functional across US and DE shards.

We are working on restoring functionality for inquiry-based flows.

Wed, Feb 4, 2026, 08:41 PM

Identified

We are seeing degraded performance across DE and US regions.

We are continuing to work to restore full functionality across all regions.

Wed, Feb 4, 2026, 08:31 PM

Identified

Functionality in DE region has been restored.

We are working to restore full functionality in US region.

Wed, Feb 4, 2026, 08:12 PM(19 minutes earlier)

Identified

We are continuing to work on a fix.

The dashboard is accessible and inquiries, verification, and workflows are intermittently being processed across all regions.

Wed, Feb 4, 2026, 08:00 PM(12 minutes earlier)

Identified

We've identified the issue and are working to restore service.

Wed, Feb 4, 2026, 07:55 PM

Investigating

We're experiencing a service outage as of 19:24 UTC. Our team is actively investigating the issue. We'll post an update soon

Wed, Feb 4, 2026, 07:24 PM(31 minutes earlier)